Skip to main content (Press Enter)
Helcim Logo
Click here if you return to contents

Supported Browsers for Your Helcim Account and Helcim.js

These are the web browsers supported by Helcim Commerce and Helcim.js


Supported Browsers

Helcim Commerce is compatible with:

Customer Facing Helcim.js is compatible with:

  • All web browsers

Unsupported Browsers

Helcim Commerce is not compatible with:

  • Internet Explorer (IE)

Helcim Commerce is not compatible with Internet Explorer because the browser is no longer supported by Microsoft and is not being updated. Due to the sensitive information Helcim handles on behalf of your business and your customers, we are unable to make our full Helcim Commerce platform compatible with IE. If your customers access Helcim.js using an IE browser, they will still be able to submit their payment information.

Related Articles

Getting Started

Was this article helpful?

Feedback submitted - Thank you!